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1. はじめに

先に公開した「X-Plane 11 用シーナリー」は WorldEditor (通称 WED) や Blender を使っ
てオブジェクトをシーナリに組み込む際の基礎的な約束事を解説していました。
この資料 「X-Plane 11 用シーナリー(拡張偏)」では、特別なツールを使うなど新しい
方法でシーナリを作成する方法を解説します。解説内容は以下の通りです、順番はバ
ラバラですがご理解下さい。

2 項：DSM ツールにてダイナミックシーナリを変更する例を示します。

3 項：MUXP ツールにて地形メッシュ(.dsf) を更新したり、地形メッシュを Blender
ファイルに変換したりします。別資料(XP11 用 DSF ﾌｧｲﾙ修正と OSM ﾃﾞｰﾀ導入) か
ら移行しました。

4 項：Blender に Blender-OSM アドオンを搭載し、OSM データを Blender ファイルに取

り込みシーナリに使います。別資料(XP11 用 DSF ﾌｧｲﾙ修正と OSM ﾃﾞｰﾀ導入) から
移行しました。

5 項：Blender の Custom Light 機能を使って Billboard(常にユーザ方向に向いている板) 
を作ります。

なるべく作成画面の画像を載せ分かり易く解説したつもりです。内容に誤りがあれば
ご指摘よろしくお願いします。

この資料がそれら作業の補助になれば幸いです。なるべく作成画面の画像を載せ分か
り易く解説したつもりです。内容に誤りがあればご指摘よろしくお願いします。
なお、この資料では以下のアプリを使用しました。これらのアプリの使い方について
は、この資料では述べません。
・WorldEditor 2.3.1 (通称 WED) 
・X-Plane 11.5 (64 bit)
・Blender V2.83 に以下のアドオンを追加

XPlane2Blender V4.1 
Blender-OSM (Basic model)　

・GIMP 2.10
・Notepad++
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2. ダイナミックシーナリーの拡張        

2.1 ダイナミックシーナリー概要
X-Plane 11 は位置が固定されたシーナリの外に、ダイナミックシーナリーと呼ばれる動

くオブジェクトを表示する事が出来ます。V11.5 では以下のオブジェクトがディフォル
トで表示可能です。

表 1　標準ダイナミックシーナリー

Nimitz.obj
  

 

Perry.obj Sailboat.obj 

            

OilPlatform.obj

       

OilRig.obj Balloon1.obj

            

Balloon2.obj
            

Balloon3.obj
               

Balloon4.obj deer_buck.obj

　　雄鹿
　 no image
 

deer_doe.obj   

　　雌鹿 
   no image

seagull_far.obj   

seagull_flap.obj

  

 

seagull_gride.obj     
                

               

           

これら.obj ファイルとそのテクスチャファイルは、X-Plane の以下のフォルダに格納さ
れています。

             .. / X-Plane 11 / Resources / default scenery / sim objects / dynamic

これ以外のオブジェクトを表示させたい場合は、同じオブジェクト名で別オブジェク

トファイルに差し替えるしか有りません。幸いな事にこの操作を行うプラグイン DSM 
(Dynamic Scenery Manager) が X-Plane.org から公開されました。

DMS で行うファイル交換作業は具体的に以下の通りです。

1) Dynamic フォルダ内の.obj ファイル（例えば Nimitz.obj）を仮の名称(例えば (back-
up)Nimitz.obj)に変更します。

2) 入れ替えるオブジェクトファイル（例えば IJN_Carrier_ZUIKAKU.obj）の名前を

Nimitz.obj に変更し、テクスチャファイルと合わせて Dynamic フォルダに移動しま
す。

X-Plane 終了時は標準のダイナミックシーナリーに戻されます、つまりダイナミック
シーナリ変更は保存されません。

DSM を使う場合は、標準ダイナミックシーナリーのオブジェクトに記載のテクスチャ
ファイルの拡張子と、実際に添付されているテクスチャファイルの拡張子が一致して
いる必要があります。これが一致していない場合は DSM は動作しません。

その場合は 2.2.2 項の通り、標準ダイナミックシーナリの obj ファイルを修正する必要
が有ります。
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2.2 DSM の設定

2.2.1 インストール                                
X-Plane の動作不良を回避するため、以下のファイル操作を理解し個人の責任でインス
トールして下さい。

注意：
インストール失敗または将来の X-Plane 異常終了の時の為、下記 dynamic
フォルダ内を全てバックアップを取って下さい。そうしないと復帰に大変
苦労することがあります。
　　.. / X-Plane 11 / Resources / default scenery / sim objects / dynamic
                                   

インストール手順

1) 以下より DSM をダウンロードします。

Dynamic Scenery Manager - Utilities - X-Plane.Org Forum (x-plane.org)

2) ダウンロードしたフォルダの中から DMSv0.16 フォルダを以下の場所にコピーしま
す。
　.. / E-Pxplane 11 / Resources / plugins 

3) ダウンロードしたフォルダの dynamic フォルダの下に以下のフォルダがあります。

extra_animals
extra_balloons1
extra_balloons2
extra_balloons3
extra_balloons4
extra_birds
extra_carriers
extra_frigates
extra_platforms
extra_rigs                           

これらフォルダを全て以下のフォルダにコピーします。                       

　　.. / Explane 11 / Resources / default scenery / sim objects / dynamic /

4) X-Plane を起動し、フライトの設定画面で上部メニューから、Plugins → Dynamic 
Scenery Manager の順に選択出来ればインストール完了です。

   

2.2.2 (重要)使用前の確認事項

標準シーナリオブジェクトの.obj ファイルが定義するテクスチャファイル拡張子と、

dynamic フォルダ内のテクステャファイルの拡張子が一致していないと事がよく有りま

す。この場合 DSM ではエラーとなりファイル交換しません。(X-Plane は正常に動作し

ます)                                                                                           

確認方法（Nimitz の場合）以下の通りとなります。

dynamic フォルダに以下の様な Nimitz の obj ファイルとそのテクスチャファイルが収納
されている場合があります。                                   

　　.. / dynamic 
　　　　：
　　　　├Nimitz.obj (Nimitz のオブジェクトファイル)
　　　　├Nimitz.dds (Nimitz の昼用テクスチャファイル .dds )
　　　　├Nimitz_lit.dds (Nimitz の夜用テクスチャファイル .dds )
　　　　├Nimitz_nm.png (Nimitz の凹凸ようテクスチャファイル .png )
　　　　：

この Nimitz.obj をテクストエディタで開くと、その冒頭部分が下記の様になっている事
があります。

＜Nimitz.obj の冒頭部分＞

I
800
OBJ

TEXTURE                     Nimitz.png　　　　　(Nimitz の昼用テクスチャファイル .png )
TEXTURE_LIT             Nimitz_lit.png              (Nimitz の夜用テクスチャファイル .png )
TEXTURE_NORMAL  Nimitz_nrm.png　　　(Nimitz の凹凸用テクスチャファイル .png )
　　　　　　　： 

先頭の TEXTURE 文がそのオブジェクトが引用するテクスチャファイルを定義します。
この例では、昼用と夜用のテクスチャファイルの拡張子が異なっていることが有りま

す。このままだと DSM は正常に動きません。テクストエディタにて Nimitz.obj の.png
を.dds に修正する事が必要です。X-Plane の動作にほぼ影響ありません。            
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2.3 空母`瑞鶴`の追加

太平洋戦争中に稼働していた空母`瑞鶴`
をダイナミックシーナリーで再現します。
X-Plane には Nimitz という空母が標準搭

載されています。ここでは DSM を使っ

て Nimitz を空母`瑞鶴`に置き換え使用し
ます。その為事前にインストールされた
DSM のフォルダに、`瑞鶴`のモデルをコ
ピーして使用します。

また、本モデルでは機体の配置場所を指
定する為にカタパルトを装備しましたが、実際の空母には装備されていません。その
為、下記　項に記載のカタパルトを使わない発艦を推奨します。

2.3.1 インストール   

本モデルは以下よりダウンロード出来ます。
https://sky-dreamer.lsv.jp/air-museum/wp-content/uploads/2021/01/IJN_Carrier_ZUIKAKU.zip

ダウンロードしたフォルダを下記 extra_carriers フォルダ にコピーします。        

.. / Explane 11 / Resources / default scenery / sim objects / dynamic / extra_carriers

2.3.2 使い方                                      

1) 空母に乗せる機体を選択し、海岸に近い任意の空港を選び X-Plane を起動します。

2) 画面上部のメニューから Plugins → Dynamic Scenery Manager → Carriers → 
IJN_Carrier_Zuikaku を選択するとその欄に●印が入ります。そのまま上位の

Update Scenery メニューをクリックすると空母切り換え作業が開始され、しばらく
するとコックピット画面に戻ります。

3) 画面上部のフライト → フライトの設定メ
ニューを順にクリックしまる。画面右上の
場所変更ボタンをクリックし、右上のカス
タマイズボタンをクリックします。

                       

 

4) 画面左下の特別な場所から離陸ボタンをクリックします。

5) ★空港名リスト(右図)から以下のいずれかの
開始場所を選びます。

　　空母発艦の場合は：Carrier Cat Shot          

　　空母着艦の場合は：Carrier Approach

6) 確認ボタンを押下し、新規フライトの開始ボタンを押下（必要なら複数回押下）し
ます。

7) 足りないシーナリ画面が出たら海のみで続けるボタンを押下します。
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2.3.3 機体操縦の要領    
1) 発艦操作方法

開始位置に Carrier Cat Shot を選ぶと空母上に機体が表示されます。このまま B キー
を押下するとカタパルトを使った発艦が出来ますが、実際とは異なった動きになり
ます。以下の方法でカタパルトを使わない発艦する事を強く推奨します。

① ジョイスティックのボタン又はキーボードのどれかに空母のキャットショット

を設定しておきます。(初回のみ)

② エンジンをアイドルにします。                                           

③ B キー(ブレーキ解除)を押下し、すぐ空母のキャットショットボタンを押下しま
す。機体は少し前進して停止し、カタパルトから外れブレーキがかかった状態
になります。

④ フラップを降ろし、エンジン出力を上げ尾輪が少し浮く状況になったら B キー

を押下(ブレーキ解除)し発進します。

2) 着艦操作方法
爆弾等は投棄し、ギアを下げ、着艦フックを下ろし、フラップを最大下げます。カ
ウルリングのすぐ上に空母が見える姿勢（なるべく水平な姿勢）で速度を70ノット
程度 (機体によります) に保ち空母に接近します。この時、飛行甲板の左右両側に
緑と赤の着陸誘導灯が見えます。着陸誘導灯の緑と赤が上下同じ高さに揃うように
します。この時の侵入角度6.5°で理想的な角度で、空母は下図の様に見えます。
飛行甲板に三点着陸する様にする事を目指します。最後に、機体が停止したら、ブ

3) 飛行機昇降機の上下
風防を開くと昇降機が下がり、閉じる
と上がります。ジョイスティックのボ
タンまたはキーボードのどれかに キャ
ノピーを切り換え 機能を設定しておけ
ば、そのボタン押下で操作出来ます。

従ってこのモデルを使う場合は、空母
に着艦する時に風防を閉じ、飛行機昇
降機を上げておく必要があります。 
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2.4 空母モデル作成例（瑞鶴）  
DSM プラグインで使える空母 `瑞鶴` の作成を以下に記載します。ここでは Luaファ

イルを修正する作業も入りますが、Lua 言語は知らなくても問題ありません。また、

空母の飛行甲板に飛行機を置く為に obj ファイルの修正が必要となります。その為 obj
ファイルをテキストエディタで修正する作業が入ります。

モデルは以下のファイルから構成されます。

＜モデルのフォルダ構成＞
IJN_Carrier_ZUIKAKU
　├ DSMconfig.lua
　├ IJNCarrierZUIKAKU.obj
　├ IJNCarrierZUIKAKU.png
　├ IJNCarrierZUIKAKU_night.png
　└ IJNCarrierZUIKAKU_normal.png

2.4.1 .lua ファイルの修正

ファイルの名称、DSMconfig.lua、は固定です。類似の標準ダイナミックシーナリー

から.lua ファイルをコピーし修正します。.lua ファイルはテキストエディタで開き、

修正する事が出来ます。この例では以下の様に修正しました。

各設定項目の意味は次ページを参照してください。指定されていない項目は Nimitz
の設定値が使われます。

＜瑞鶴用 DSMconfig.lua の修正例(太字)＞
settings = {

displayed_name = "IJN_Carrier_ZUIKAKU",
author = "Tanzai",
carrier_deck_height_mtr = 14.13,
carrier_ILS_offset_x_mtr = 3.0,
carrier_ILS_offset_z_mtr = 3.0,
carrier_approach_heading = 0.0,
carrier_catshot_heading =  0.0,
carrier_catshot_start_x_mtr = 0.0,
carrier_catshot_start_z_mtr = 13.8,
carrier_catshot_end_x_mtr = 0.0,
carrier_catshot_end_z_mtr = -123.0,
test = "IJN_Carrier_ZUIKAKU config is good",

}
----------------------------------------------------------------------------------------------------
------END OF CONFIG SETTINGS, DO NOT EDIT PAST THIS POINT-----------
----------------------------------------------------------------------------------------------------
（以下略）

設定項目の意味：

displayed_name DSM メニューに表示される名称、空白あっても可。

author モデルの作者名を入れます。

carrier_deck_height_mtr モデル原点からの飛行甲板の高さ(m)

carrier_ILS_offset_x_mtr モデル原点からの右舷方向の位置(m)

carrier_ILS_offset_z_mtr モデル原点からの船尾方向の位置(m)

carrier_approach_heading 空母着艦時の進入角度(°)、船首方向から左舷への

角度を+とする。

carrier_catshot_heading 空母着艦時の進入角度(°)、船首方向から左舷への

角度を+とする。

carrier_catshot_start_x_mtr カタパルト開始位置(m)、モデル原点から右舷方向

を+とする。(確認要)

carrier_catshot_start_z_mtr カタパルト開始位置(m)、モデル原点から船尾方向

を+とする。

carrier_catshot_end_x_mtr カタパルト終了位置(m)、モデル原点から右舷方向

を+とする。(確認要)

carrier_catshot_end_z_mtr カタパルト終了位置(m)、モデル原点から船尾方向

を+とする。

test ログファイルに記載する文を設定する。

                                                                             
モデル原点とは Blender の obj の原点です。

着艦制動索の設定項目は有りません。X-Plane は carrier_deck_height_mtr や
carrier_approach_heading から何等かの条件で機体を検出し、停止させる様
です。
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2.4.2 .obj ファイルの作成
.obj ファイルは XPlane2Blender で変換されたテクストファイルです。作成手順は機
体作成とほぼ同じですが、以下部分が異なります。

1) 使用する obj ファイルは一個のみです。Blender 内では複数の子 obj があってもか

まいませんが。一つのレイヤにまとめ X-Plane オブジェクトに変換します。

2) オブジェクトの原点（モデルの原点）は喫水線の高さで船の中心線上に配置しま

す。更に X-Plane に表示される Nimitz の航跡がモデルと違和感がない様な位置に

調整します。Nimitz の航跡の大きさは修正出来ないのでそのまま使います。

3) アニメーション設定は可能です。Dataref は飛行機の物と同じものを使います。飛

行機の扱いに影響のない Dataref を選んで使います。

4) Normal Metalness の設定は可能です。機体作成メモ (下記参照) の 8.2.2 項を参照し

Normalmap ファイルを作成し、.obj ファイルの TEXTURE_NORMAL 文で指定し
ます。
https://sky-dreamer.lsv.jp/air-museum/wp-content/uploads/2020/11/d20a5ad56b2080ba7a
e0f28597ea9be4.pdf                                                                                              

5) LOD の設定は出来ない様です。                                            

6) 飛行機等が載る部分等（飛行甲板）には、obj ファイルを修正して表面を固くす
る指定が必要です。詳細は　項を参照して下さい。

2.4.3 .obj ファイルの hard 設定

空母オブジェクト IJN_Carrier_ZUIKAKU.obj に hard設定します。その為には、.obj をテ

クストエディタで開き ATTR_hard 文と ATTR_no_hard 文を追加しますが、どこに追加
するかが問題です。

このファイルは XPlane2Blender で作成された膨大なテクストファイルですが、注目す

る場所 TRIS 文の場所（最後に近い部分）だけです。

参考までに、.obj に記載される主な命令文は以下の通りです。

TEXTURE    <ファイル名> 　昼間のテクスチャファイルを指定

TEXTURE    <ファイル名> 　夜用のテクスチャファイルを指定

TEXTURE_NORMAL    <ファイル名> 　凹凸を表現するテクスチャファイルを指定

TRIS <最初の節点番号> <節点の数> 　指定した節点のメッシュを作成
ANIM_begin 　ここからアニメーションを記載開始

ANIM_end 　　　　　 　アニメーションの記述をここで終了

その外の命令文は下記より OBJ8(.obj) File Format Specification を参照してください。

OBJ8 (.obj) File Format Specification | X-Plane Developer (x-plane.com)                                     

IJN_Carrier_ZUIKAKU.obj を開くと以下の内容になっています。アニメーション記述か

ら飛行甲板の TRIS が分かりまっしたので、その前後に ATTR_hard 文と ATTR_no_hard
文を追加しました。                                                           

＜IJN_Carrier_ZUIKAKU.obj＞                                                  
I
800                                                                        
OBJ
                                                                                       
TEXTURE IJNCarrierZuikaku.png
TEXTURE_LIT IJNCarrierZuikaku_night.png
TEXTURE_NORMAL IJNCarrierZuikaku_normal.png
NORMAL_METALNESS
GLOBAL_specular 1
POINT_COUNTS 23709 0 30 23709                                
　： 
（中略）
　：
TRIS 15894 2574
TRIS 0 2616

TRIS 3048 8631
TRIS 22773 126

TRIS 2760 36
TRIS 2796 36

　　　　　　　　　 ：
　　　　　　　　　　　（途中の TRS 文は省略）
　　　　　　　　　　　　 　：

TRIS 2832 36
TRIS 2868 36

TRIS 14352 282
TRIS 14760 1134
TRIS 18468 900
TRIS 19368 3405
TRIS 23193 36
TRIS 23229 18
TRIS 23247 132
TRIS 23379 330

ATTR_hard                                                  
TRIS 12075 2277

ANIM_begin
　　　　　　：
　　（途中の機体昇降機のアニ
　　　メーション設定記載は省略）
　　　　　　：

ANIM_end
ATTR_no_hard
LIGHTS 0 1                                                    
　　：
（以下略）
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アニメーション定義があるのでこ
の部分は飛行甲板と判断される。

この文を追加

この文を追加



3. 地形メッシュ(.dsf)を修正する      
この項では、MUXP ツール(今回は v0.4) を使って X-Plane の地形メッシュ(.dsf) を切り

出し、その部分を Blender(.blend) に変換する方法を示し、そのファイルを修正した後

に元の dsf と入れ替える方法を解説します。

残念ながら、現状の MUXP ツールで修正した地形データを一般のユーザに配布するの
はあまり進められません。その理由は、処理に必要なファイル構成が煩雑で、修正済

dsf ファイルを削除したり Undo する機能が無い為、ユーザ先でシーナリー復旧するの
が難しいかと思えるからです。シーナリー復旧する為には、修正作業で作成したファ
イルを認識し手作業で元に戻す必要あります。

ただし、MUXP ツールを使って地形メッシュを Blender ファイルに変換し、その地形

の上に OSM データの建物を展開する場合に使えます(4.2.3 項参照)。
この項では地形メッシュを Blender ファイルに変換する手順を主に説明します。

また、現状の  MUXP  は  OrthoPhoto  シーナリは扱えない様です。　MUXP による

Elevation の指定によっては OrthPhoto シーナリが扱えない場合があります。

3.1 MUXP とは

MUXP (Mesh Updater X-Plane の略) とは、Custom Scenery 内のフォルダ

(zzzz_MUXP_default_mesh_updates) に置かれ、地形メッシュ(dsf)の形状を修正し、

その部分のデータを .obj や .kml 形式で出力するツールです。

一例として広島シーナリー(Hiroshima_updated) で地形メッシュを切出す手順を示しま
す。

(1) Custom Scenery フォルダの下に新規シーナリフォルダ (今回の例では

Hiroshima_updated) を作成します。その下に地形修正情報を記載した MUXP ファ

イル (Hiroshima_to_extract.muxp) を保存します。詳細は 3.2.1 項参照。

(2) Windows エクスプローラーにて前記 MUXP ファイル (Hiroshima_to_extract.muxp) 
を zzzz_MUXP_default_mesh_updates フォルダの muxp.exe の上にドロップする

と”Windows によって PC が保護されました”画面が出るので 詳細情報 をクリッ

クし 実行 ボタンをクリックします。MUXP ツールが起動します。

(3) MUXP 画面が表示され、次に“Select DSF File to update:” 画面が表示され X-Plane
に実装されている dsf がリストアップされます。地形を切出したい dsf を選択し 

OK をクリックします。

少し後に muxp_mesh.obj が作成されます。このファイルが切出した地形の

Wavefront オブジェクトで Blender に変換できます。詳細は 3.2.2 項参照。

 Custom Scenery /
　├ Hiroshima_updated /
　│　├ Hiroshima_to_extract.muxp ・・・・(1)で準備する。 　　　　

　│　└ muxp_mesh.obj ・・・・(3)で作成される。
　：

　└ zzzz_MUXP_default_mesh_updates /
　　　├ license.txt
　　　├ muxp.exe ・・・・(2)で実行する。

　　　└ README.txt

MUXP ツールはまだ開発段階なので、個人の責任のもとに使用する事が求められてい

ます。不明な点があれば MUXP に同梱のマニュアル(MUXP-Manual.pdf) を参照してく
ださい。

3.1.1 MUXP のインストール

こちら を開き、右側の MUXP をクリックするとダウンロード画面が表示されるので
以下のファイルをダウンロードします。

MUXP_Win64_EXE.zip
MUXP-Manual.pdf

Cutom Scenery の下に zzzz_MUXP_default_mesh_updates の名称でフォルダを作り、

その中に MUXP_Win64_EXE.zip を解凍します。最終的に以下のフォルダーを Custom 
Scenery 内に作成します。

zzzz_MUXP_default_mesh_updates
　├ license.txt
　├ muxp.exe
　└ README.txt

次に X-Plane を起動し Flight Configuration 画面を出し停止します。Custom Scenery
フォルダ内の scenery_packs.ini を開き、zzzz_MUXP_default_mesh_updates の行を
一覧表の一番下に移動します。
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3.2 地形メッシュを 3D ファイルに変換
以下の 3.2.1 項 → 3.2.4 項の順に操作します。 

3.2.1 切り出し用 MUXP ファイル作成
Custom Scenery 内にシーナリーパックとなるフォルダ(今回は Hiroshima_updated) を
作成します。テキストエディタで下図の様な文を作成し、Hiroshima_to_extract.muxp 
等の名称で保存します。今後はこの Hiroshima_updated を作業フォルダとします。

メッシュを切出す座標(緯度 経度) は事前に GoogleEarth などで調べておきます。

なお、空港エリアを修正しその部分を平坦にしたいだけの場合は、MUXP ファイルを

自分で作成する必要は有りません。WED で空港エリアを修正し MUXP ツールで

MUXP ファイルを作成するのが簡単です。詳細はツールに添付の MUXP-Manual.pdf 
を参照下さい。

Hiroshima_to_extract.muxp の例

muxp_version:　MUXP の版数では 0.4 を指定します。(2021 年 8月時点)

id: 　他と区別できる MUXP 名称(スペース混在不可)、修正内容を含めても可。
この名称でバックアップされます。

version: このMUXPファイルの版数、小数点含めても可。

description: シーナリの説明文(必要なら記載)
author: 作者名(必要なら記載)

tile: 切り出し領域が含まれるタイル(1°単位の緯度経度のエリア) を
指定する。(スペース無)

area: 南側緯度、北側緯度、東側経度、西側経度の順にスペースをはさ

んで入力します。ただし下記 coordinates: より少し外側の事。

source_dsf: 修正元のdsfファイル (この項目は実行時に指定したいので、こ

の行の先頭に#を追加し無効にしています。)
extract_mesh_to_file: 　dsf を 3D ファイルに切り出す MUXP ファィル名を指定しま

す。この欄を空欄にすると、ファイル名はディフォルトの

muxp_mesh.obj を使う事になります。

coordinates: 切り出しエリアの4隅の緯度経度を時計回りに記述します。最初
と最後は同じ緯度経度になります。(東西南北に面したなるべく
正方形が良いかと思われます)

3.2.2 Wavefront の地形ファイル作成

(1)  Windows エクスプローラー上で、3.2.1 項で作成した MUXP ファイル

(Hiroshima_to extract.muxp) を zzzz_MUXP_default_mesh_updates 内の

muxp.exe にドラッグアンドドロップします。下図 MUXP 画面が現れ自動的に(3)、
(4)に進みます。

MUXP File 欄に目的の MUXP ファイルが表示されている場合は、そのまま Start 
muxp ボタンを押し(3)→(4) に進みます。

MUXP ファイルを変えたい場合は Select ボタンを押し指定し選択し直します。

MUXP ツールの詳細設定を変更したい場合は Config ボタンを押し(2) に進みます。
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muxp_version: 0.4
id: Hiroshima_updated
version: 1.0
description: Stone wall added along the river and castle
author: Tanzai
tile: +34+132
area: 34.37 34.42 132.42 132.48
#source_dsf: DEFAULT ### REMOVE THIS LINE IN ORDER TO SELECT DSF 
FILE ####

extract_mesh_to_file:
   coordinates:
   - 34.4116 132.4286
   - 34.4116 132.4751
   - 34.3763 132.4751
   - 34.3763 132.4286
   - 34.4116 132.4286
   
exit_without_update:



(2) Config 設定画面 (下図) が開くので、必要事項(次頁) を設定し最後に SAVE ボタン

を押します。この設定は muxp.cofig として作業フォルダーに保存されます。

設定後はこの画面を消去し、(1)に戻ります。

Config 設定内容：

X-Plane base folder:　X-Plane がインストールされたフォルダーを指定します。

Select ボタンを押し選択できます。

Folder to updated DEFAULT dsf: 修正された dsf ファイルが収納される

フォルダです。通常は Select ボタンを押して、Custom Scenery
内の zzzz_MUXP_default_mesh_updates を指定します。

Create folder for updated dsf ボタンを押しても同じフォルダ

が指定されます。このフォルダは MUXP ツールの作業用に使わ
れます。

Export to kml kml ファイルを出力したい場合はチェックします。Google Earth 
で見れる様です。

activate Pack チェックすると、修正した dsf ファイルが X-Plane で見れるよう

に scenery_packs.ini を修正します。dsf を修正して X-Plane で見
たい場合に有効です。

補足：scenery_packs.ini の中にインストールされた dsf ファイル（HD
メッシュや Ortho メッシュ等）があればそのすぐ上に

zzzz_MUXP_default_mesh_updates が配置されます。それら dsf
ファイルが無ければ一番下に配置されます。

Fixed source for dsf (optional): 　修正元にする dsf ファイルを指定します。

Select ボタンを押すと Global メッシュ、HD メッシュ、Ortho
メッシュ等が表示されるので、修正したい dsf ファイルを選択し
ます。
空欄にすると MUXP スタート後に dsf ファイル選択画面が表示
されるので、そこで指定します。

[ACTIVE] にすると、その時点で X-Plane が表示する dsf ファイ
ルが自動的に選ばれます。

Conflict strategy (optional): 　修正した場所が、過去に修正された場所と重複し
地形に矛盾が生じた場合の処置を指定します。
ORIGINAL ：元の dsf ファイルに修正を施します。

BACKUP　：直前に修正した dsf ファイルに、前回と違う場所の
修正を施す場合の様です。

IGNORE 、CURRENT 、CANCEL は使わないほうが良いとのこ
と。

(3) 下図の様な dsfファイル選択画面が出た場合は、修正したい dsfファイルを選び　

OK をクリックします。X-Plane のディフォルト dsf を使う場合は DEFAULT をク

リックし OK をクリックします。

                                                                          11 / 29                                                                                                              



(4) 少し後に下図の画面が表示されますがこれで dsf 切出し完了です。

作業フォルダ(今回は Hiroshima_updated) に muxp_mesh.obj が作成されます。こ

れは Wavefront ファイルです。

この.obj ファイルをテキストエディタで開くと、最初のコメント欄に Scale 値(赤字

部)が表示されます。後で Blender オブジェクトに変換した時、地形メッシュをこ
の倍数だけ縮小する必要があるので値をメモしておきます。

<muxp_mesh.objの内容抜粋>

# X-Plane Mesh Extract by MUXP (version: 0.4.0 exp)
# from scenery pack: Custom Scenery/zzz_hd_global_scenery4
# dsf file hash: b'\x17\xc5\x05G&\xdb\x94\xfc\xae;\x9b}\x874\xd89'
# Coordinates given are x (longitude), y (latitude, forward), z (elevation, up)
o CENTER_Coordinates
# coordinates relative to center: 132.45184999999998 34.393950000000004 0
# used in Mercator projection: 14744472 4081823 0
v 0.014 0.744 0.472
v 0.004 0.081 0.823
v 0.0 0.0 0.0
vn 0 0 1
f 1//1 2//2 3//1
# Scale x axis by 0.8236944183918316 and y axis by 0.822804862153248 for 
having meters as scale
o MESH
v -1530.803 1617.402 0.0

3.2.3 切り出した地形をBlender で見る
(1) Blender で File → Import → Wavefront (.obj) のメニューを選択し、現れた画面右

側で作成した muxp_mesh.obj を選択し、▼Transform 欄で以下の様に座標軸を変

更します。(Y Forward を選択すると自動的に Zup になります。)
　　Foward  → Y Forward
　　Up          → Z Up

その後、先に作成した muxp_mesh.obj を指定し、Import OBJ ボタンを押します。

(2) Blender の Outliner 画面に MESH というオブジェ
クトが現れます。このオブジェクトが地形メッ
シュです。
このオブジェクトは 3.2.3 項で OSM データの建物
等を配置する地盤として使うことが出来ます。

(3) 3D 画面右側の View タブを開き End 欄に 20000 を設定します。

更に画面上側の　　(Wireframe) を選択し画面を引くと、以下の様な地形メッシュ
画像が現れます。
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(4) 右側の Item タブを選択し、Scale: 欄の X および Y に前

項の(4) でメモした値を入力します。MESH 画像が少し縮
むはずです。

その後 Apply → Rotation&Scale を選択し、変更を確定

します。Scale: の値が全て 1.0 になれば OK です。

(5) MESH オブジェクトを真上から眺めた形状が四角形でない場合、MESH オブジェク
トの原点が切出し区画の中心からズレている可能性が有ります。この場合は後に

ED で指定する緯度経度と地形メッシュの位置がズレます。

Blender の編集モードで、地形メッシュの中心位置が Blender の原点に来る様に、
地形メッシュの位置をズラシます。

最後に Apply → Position を選択し修正を確定します。

3.2.4 切り出した地形にテクスチャを貼る

地形メッシュの形状を修正する時の補助としてテクスチャを貼るのが有効です。ただ

し、このテクスチャは修正後の dsfファイルには使われません。あくまで修正作業の
補助として使います。

(1) テキストエディタを使って右の内容を作成し　　　

<任意名称>.hlg の名前で、作業フォルダーに格納
します。

Zoom 　画像の解像度の指定です。17 程度で良い
様です。

PointLon_0 ～PointLat_3 　左上の角を Point 0 とし時計回りに Point 0 → Point 3 
の四角形の領域の緯度 (Lat) 経度 (Lon) を指定します。(3.2.1 項の

Coordinates に合わせるべきです) 

(2) SAS.Planet を開き Maps → Bing → Bing Maps – satelite メニューを選択し、空
中写真画面にします。

(3) SAS.Planet で Operations → Open メニューを選択するとファイル選択画面(下図) 
が現れるので(1) で作成した .hlg ファイルを選択します。

更に SAS.Planet Selection Polygon を選択し、開く ボタンを押します。
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[HIGHLIGHTING]
zoom=17
PointLon_0=132.4286

PointLat_0=34.4116

PointLon_1=132.4751

PointLat_1=34.4116

PointLon_2=132.4751

PointLat_2=34.3763

PointLon_3=132.4286

PointLat_3=34.3763



(4) Selection Manager 画面が開くので画面上部の Stitch タブを選択します。

以下の項目を入力します。
Output format:　JPEG を選択します。

Save to: 　画像ファイルの保存先(作業フォルダ Hiroshima_updated) を指定します。
右の … ボタンで別画面を開き、保存先とファイル名を指定し 保存 を
クリックします。すぐ保存される訳ではありませんが、保存先とファイ
ル名のみが設定されます。

Map: 　Bing – Satellite を選択します。

Zoom: 　画像解像度を選択します。この画像の 17 の場合では下の Number of 
tiles: 欄から 2168x1995 ピクセルサイズである事が分かります。

Projection: 　Mercator / Google maps で良い様です。Mercator とはメ
ルカトル図法の意味。

最後に Start ボタンを押します。しばらく後に切り出した画像ファイル(.jpg) が上
で指定したフォルダに保存されます。

(5) 保存された画像は以後 X-Plane で使う場合は、画像編集ソフトにてファイルのサイ

ズを 2 の n乗のサイズに変換し、.png 又は.dds ファイルに変換します。

(XPlane2Blender は.png 又は.dds のファイルしか扱えません。)

(6) Blender のオブジェクトモード画面で地

形メッシュ(MESH) を選択し、右側画面

の Material タブを選択します。

Use Nodes をクリックし青色表示にし
ます。

Base Color 欄の右側の小さな〇印をク
リックします。

現れるメニューから Image Texture を選択すると、すぐ下にテクスチャファイル

選択欄が出ますから、そこに(5) で作成した画像ファイルを指定します。

(7) 通常の Blender 操作により地形メッシュにテクスチャを貼ります。

今回の例の様に、地形切り出しの.muxp と画像切り出しの.hlg で切り出し領域が同

じ場合は、Project from View (Bounds) を使うと便利です。

注意　Blender 画面の表示が良くない場合は 3.3.1 項を参照します。

                                                                      14 / 29                                                                                                                     



3.3 地形メッシュを修正

3.3.1 地形メッシュ修正時の注意
(1) 画面右上の Outliner 内にあるオブジェクト CENTER_Coordinates は移動しない事。

これはオブジェクトを所定の緯度経度に配置する時の基準になる物です。

(2) 地形メッシュの各節点(vertices) はトンネル、ループ、多い被さる崖などは不可です。
上から見て同じ場所に複数の節点は来るのは不可です。

(3) 切り出した領域の外周の節点は移動しないこと。

(4) 各メッシュの normal 方向が逆になっている事が多いです。確認必要です。

(5) Material でテクスチャを設定しても dfs に戻す時には使われません。

3.3.2 テクスチャを歪ませない様に地形を修正する方法

3.2.4 項で地形メッシュにテクスチャを貼っても、そのままではメッシュの節点を動か
すとテクスチャが歪んでしまいます。以下の方法でテクスチャを歪ませないで節点だ
け移動できる設定をします。

(1) Object モードで画面右上の Outliner 
のリストから地形メッシュ(MESH) 
を選択し、Shift D キーを押して複製
コピーします。複製された地形メッ

シュは MESH.COPY.Base と云う名
称になります。

(2) Outliner 画面で、複製した地形メッ

シュ(MESH.COPY.Base) の右側
の　　をクリックし　　にします。
これでこのオブジェクトは選択でき

なくなります。(右図)

(3) 元の地形メッシュ(MESH) を選択し Object タ
ブの Wireframe をチェックし、shadow の
チェックは外します。

Display as を Wire にします。(右図)

これで元の地形メッシュの形状を変更してもテク
スチャ画像が歪むことはありません。

3.3.3 地形メッシュの修正後の処理

修正した地形メッシュは Wavefront ファイルに変換する前に以下をチェックします。

(1) 複製コピーした MESH.COPY.Base は削除します。

(2) Edit Mode にて、

・各メッシュの normal方向は正しい事を確認します。

・Face → Triangulate Faces を全面実行します。

・Mesh →CleanUp →Merge By Distance を実行します。Merge Distance は

0.01m か？

(3) Object Mode で、

・Object → Apply → Rotation & Scale によりをサイズや角度を標準にします。

・Material のテクスチャは変更しない事。つまり Material 名は terrain_Water と
solid_default_terrain で、それぞれの Material で Use Nodes はオフの事。

・メッシュの名称は MESH の事。
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3.4 地形メッシュを元の dfs に戻す
この項の作業を行うと dsf ファイルのバックアップ等のファイル操作が複雑になりま

す。個人で使う場合は良いですが、一般のユーザに配布するのは困難な様です。
以下に概略を説明します。不明な点があれば MUXP に同梱のマニュアル(MUXP-
Manual.pdf) を参照してください。

(1) Blender にて修正完了した地形メッシュを Save した後、File → Export → 
Wavefrong (.obj) メニューを選択します。パラメータ▼Transform を Y Forward 
と Z-Up に設定し、ファイル名は例えば Hiroshima_terrain_WF.obj とし(2.4.2 項の

Name: に合わせる必要あり)、Export OBJ を実行します。

(2) 3.2.1 項で作成したファイルを参考にして下図の様なテキストファイルを作成し、 

今回の場合は Hiroshima_to_insert.muxp の名称で作業フォルダ(今回は

Hiroshima_updated) に保存します。

Hiroshima_to_insert.muxp の例

ほとんど 3.2.1 項の MUXP ファイルと同じ内容ですが、以下を指定します。

source_dsf: 　修正元のdsfファイルを指定します。今回は実行前に確認画面
で指定したいので、行の先頭に# を記載しています。

Name:  修正済のWavefrontオブジェクト名称です。空欄の場合はディフォル
トのmuxp_mesh.obj が使われます。この.obj は MUXPファイルと同
じフォルダになければなりません。

(3) MUXPを起動し、MUXP File: に上記ファイルを指定しSart muxpボタンを押します。
次に修正元のdsfファイルをどれにするか選択する画面が出るので指定します。

(4) 修正元の dsfファイルに他の修正箇所と重複する部分を修正しようとする場合、

どの dsf ファイルに修正を施すか指定する画面(3.2.2 項の(4)の様な画面) が表示さ

れます。修正したい dsf ファイルを選択し OK を押します。

(5) MUXPは修正した地形をDSFに挿入し元のdsfファイルと差し替えます。数分後に 

MUXP 画面に　Finished….. が表示され完了します。その結果、

・修正前の dsf は同じ場所に　～.dsf.muxp.original の名称で保存されます。

・修正後のバックアップは同じ場所に　～.dsf.muxp.backup の名称で保存されま
す。

　元の dsf ファイルフォルダー
　　　└ Earth nav data /
　　　　　　└ +30+130 0 /
　　　　　　　　├ +34+132.dsf.muxp.backup (修正後バックアップ)
　　　　　　　　└ +34+132.dsf.muxp.original (修正前原本)

・作業に使った MUXP ファイルは MUXP の作業フォルダに以下の様に保存されま
す。

　X-Plane / Custom Scenery /
　　├ zzzz_MUXP_default_mesh_updates
　　　　├ Installed MUXP Files
　　　　：　　　└ +34+132 Hiroshima_updated 1.0.muxp (新規)

更に Custom Scenery内の scenery_packs.ini の中身を見てみると、
zzzz_MUXP_default_mesh_updates が修正元の dsf ファイルの上に記載されてい
るので、X-Plane で表示可能な状態になっています。

X-Plane で見てみると、修正された領域がディフォルトの草地になっているのが
分かります。別途オーバレイで表面にテクスチャを施す必要あります。

注意：MUXP動作中に応答が無くなる場合があります。動作状況
はタスクマネージャーで確認できます。ハングした場合は以
下を確認します。
・MUXP 文の記載に間違いがないか。
・修正する地形メッシュにオーバーハングが無いか。

注意：修正した dsf を元に戻すツールは現在有りません。手動で
元のファイルに戻す必要があります。
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muxp_version: 0.4
id: Hiroshima_updated
version: 1.0
description: Stone wall added along the river and castle
author: Tanzai
tile: +34+132
area: 34.37 34.42 132.42 132.48
#source_dsf: DEFAULT # the mesh where you would like to insert the .obj, 
remove if you want to select

insert_mesh_from_file: 
   name: Hiroshima_terrain_WF.obj



4. OSM データを X-Plane に表示     

この項は一部内容が古くなっています。以下の資料の方が分かりやす
いです。

資料：　XP11用 OSM シーナリー作成 
場所：　https://sky-dreamer.lsv.jp/air-museum/　の資料室

以下に特定領域の OSM データを Blender オブジェクトに変換し、修正を加えシーナ
リーパックを作るまでを解説します。

以下の説明では Blender 2.83 に以下のアドオンを搭載したものを使用します。

・XPlane2Blender
・Blender-OSM (Basic model)

この種のアドオンには現在 Blender OSM と Blender GIS が有りますが、

Blender OSM の方が安定している様なので Blender OSM を使います。ま

た切妻屋根のモデルを作れるので Basic model を使います。

X-Plane で使うためには 3.2.3 項で dsf から切り出した地形メッシュ(MESH) の上に OSM
データの建物等を配置するのが良いと思われます。

4.1 Blender-OSM のインストール

このアドオンは Blender 2.8 以降にインストール可能です。また、無料でインストール

可能な base version と有料の premium version が有ります。以下の説明では、base 
version でも切妻屋根の建物を作成出来るので(下図)、こちらを使います。 

ダウンロードとインストールに手順に関しては例えば以下のサイトで詳しく紹介され
ています。

　　　　B  lender-OSM      を使ってみる  

4.2 OSM データをBlender に切り出す

Blender-OSM で OSM データを切り出す作業には、以下の 3つの段階があります。以

下に記す操作で不明な点が有れば　Documentation　のサイトを参照下さい。

(1) 緯度経度の最大最小値を指定し、切り出し領域を設定

4.2.1 項参照。後で X-Plane オブジェクトとして使うので切り出し領域は正方形に
近い形状が良いかと思われます。

(2) 地形を Blender オブジェクトに変換

4.2.2 項参照。この地形データは X-Plane に使えません。参考用に必要な場合この
作業を行います。

(3) 切出し領域内の OSM データ(建物等) を Blender オブジェクトに変換

3.2.3 項参照。日本の場合、低層建物の屋根は切妻なので gabled に指定するのが良
いかと思います。

また、建物等を配置する地形メッシュも選択できます。この指定が無いと xy平面
上に配置されます。
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4.2.1 OSM切り出し領域の設定

(1) Blender の画面右側の OSM タブを開き、

Extent: 欄の緯度と経度の範囲欄に目標
の切出し範囲を指定します。　

Select ボタンを押します。

(この時点で表示されている緯度経度は

前回設定のものなので無視します。)

OSM  の領域設定サイトが表示されます。

(2) この設定サイトで  OSM  を切り出したい領域にズームインし、Show selection 
rectangle ボタンを押します。

(3) 切り出しエリアが表示されますから領域を調整し、Copy  ボタンを押します。

(最終的には  OSM  タブの  Extent: 欄で  3.2.1  項の  Coordinates  に合わせます) 

(4) Blender  画面に戻り  Extent: 欄の Paste  ボタンを押しすと切り出し領域の緯度経度
の境界値が表示され確定します。

(2)で使った  OSM  の領域設定サイトはもう必要ないので消します。

4.2.2 地形メッシュの切り出し
前項で OSM の切り出し領域が設定されていれば、以下の手順で OSM データ内の地形

メッシュ(Terrain) を切り出すことが出来ます。

ただしこの地形メッシュは X-Plane では使えないので、この項の操作は必ずしも必要
ではありません。

(1) Blender の OSM タブを開き、

ドロップダウンリストから terrain を選択し、

その右の import ボタンを押します。

経緯度情報は使う可能性があるので Ignore
existing georeference にはチェック入れません。

またこの例では Vertex 数が 21,504 個ある事が分

かります。(右図) 

(2) 数秒後に地形メッシュオブジェクト Terrain が画

面右上の Outliner に作成されます。
次項で作成される建物等のモデルはこの地形
メッシュ上に配置する事が出来ます。

今回の例では、地形メッシュは下図の様な形状をしています。節点が密集し過ぎてい

るのと、水陸の区別が出来ていないので、このままでは X-Plane 用には使えません。
あくまで建物等をこの上に配置するためだけに作成します。
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注意　作成された Terrain は 4 km 四方の
大きさなので最初は画面で見えま
せん。
画面右の View タブで End ( 遠視

程 ) を 20000 m 程度にして、画面
を引くと見えます。



4.2.3 建物等モデルの切り出し
ここでは OSM データから地上のモデル(建物、水面、森、植物、道路、鉄道) 更に衛星

画像も同時に切り出されます。なお、OSM データの切り出し領域は既に 3.2.1 項で設
定されているものとします。

(1) ドロップダウンリストから OpenStreetMap を選択します。

(2) ▼Settings の Import from: 欄でドロップダウンリストか

ら server を選択します。

注　もし OSM データのファイルがある場合は、この項で

file を選択し、その場所を指定します。

(3) Terrain: 　OSM データを配置する地形を指定します。■

をクリックし該当地形メッシュ(今回は MESH) を指定しま
す。
3.3 項に記載した地形メッシュに必要な修正は施されてい
るものとします。

(右側の注 1 参照)

(4) 3D ボタンは選択したままにします。

(5) 作成対象にチェックします。

(6) Default roof shape: は以下のどちらかを選びます。

　flat 陸屋根の場合

　gsble 切妻屋根の場合

(7) Level height
各階の高さ（ある階と直上の階の床の高さの差）を指定し
ます。とりあえずディフォルトの 3m のままにします。

(8) Default number of levels: 
OSM データに建物の高さ又は階数の情報がない場合があ

る様です。Blender-OSM はここで示す分布でその建物の
高さを推定します。その分布をここで規定します。

　Levels 　対象の階層

　weight　その階層が占める割合

　+ と - 　階層の割合指定を増減させる。

(9) Import as a single object:
ここは必ずチェックを入れます。

(10) Ignore existing georeference:
 経緯度情報は使う予定なのでチェック入れません。

(11) 最後に import ボタンを押します。

約 1 分後に右図の様な OSM モデルが
作成されます。
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注１　この欄を空欄にすると建物等の

モデルは xy 平面上 (Z=0) に配
置されます。

X-Plane で使う場合は 3.2.3 項
の dsf から切出した地形メッ

シュ (MESH) を指定し、その
地形の上に建物等モデルを配
置するのが良いようです。



4.3 OSM オブジェクトを Blender で修正
Blender-OSM で作成されたオブジェクトはそのままでは X-Plane では見れません。以
下の調整が必要です。

4.3.1 Blender 画面の事前設定
Blender 2.8+ で画面が適正に表示される様に初回のみ以下の設定をします。

(1) 画面右の Render タブ　　　で Render Engine 
が Eevee である事を確認します。

(Cycles でも良いですが Workbench は使えませ

ん。)

(2) 3D 画面右上の Shading 選択で　　を押し、その右の　　をクリックします。更に、

・Scene World をチェックします。

・Render Pass を Combined にします。これでテクス

チャが表示されます。(右図)

(3) 3D 画面右上の Shading 選択で を押し、その右の　　をクリックします。更に、

・Scene World をチェックします。

・Render Pass を Combined にします。これでテクス

チャが表示されます。(右図)

(4) 3D 画面右上のShading 選択で、　　を押し、
その右の　　をクリックします。

Lighting: 欄のボールを、画像が明るく見えるも
のに変更します。
更に Color 欄を Texture にします。
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4.3.2 Blender オブジェクトの修正ヒント

この項に記載の内容は古くなっています。詳しくは以下の資料を参照
して下さい。

資料：　XP11用 OSM シーナリー作成 
場所：　https://sky-dreamer.lsv.jp/air-museum/　の資料室

Blender-OSM で作成されたオブジェクトを  X-Plane  用に修正する為のヒントを以下に
記載します。

(1) 建物の屋根と壁を別々に  UV 展開
Blender 2.8+ を使って  OSM  から切り出された建物は、屋根と壁面が別々の  Material
となっています。
　屋根： roof
　壁面： wall
X-Plane  用オブジェクト(OBJ) にする為に  1  つの  Material にしますが、せっかく

Material  が分かれているので今の内に屋根と壁面の  UV  展開を済ませます。

①　建物オブジェクトを  Edit Mode で真上から見た画面にします。

②　屋根の面  1  つを任意に選択し、Select → Select Similar → Material を選択します。

③　屋根面が全て選択されますからそれを  UV  展開します。展開先のテクスチャは
屋根面と壁面の両方に使えるものである必要があります。

④　壁面も同様にして  UV  展開します。

(2) 建物のオブジェクトの  Material を  1  つにする

Edit Mode  で対象メッシュ全てを選び、右画面の  Object タブの　＋ボタン　にて新

規に  Material を追加し、名前を付けます。最後に  Assign ボタンを押し設定します。

不要となった  Wall  と  Roof  の  Material  は     －ボタン　にて削除します。

新規  Material の設定は 4.3.4  項を参照して下さい。

（この作業は後で戻せないので、屋根と壁面の  UV  展開を済ませたほうが良いかと
思います。）

(3) 建物の高さで屋根の形を分ける方法

日本の家屋は、3  階以下の建物は切妻屋根(Gable) 、4  階以上の建物は陸屋根(Flat) 
である事が多いです。幸い  Blender-OSM  (Basic model)では切妻屋根と陸屋根のモ

デルを作ることができるので、3  階以下と  4  階以上で建物の屋根の形を切り分ける

ことにします。具体的には各建物の軒高が  9m  以下か以上かで切り分けたいと思い
ます。
なお、軒高は建物の垂直線の長さで判断出来ます。

3  階以下の建物 (切妻屋根で軒高  9m  以下)を切出す方法

以下の手順があります。6.2.4  項に更に詳しく解説しています。

①　建物を切妻屋根(Gable) 指定で  OSM  から  Blender  に展開します。(3.2.3  項)

②　Edit Mode  で垂直線の  1  つを選択し、垂直線すべてを選択(Select → Select 
Similar → Direction)し、その逆を選択(Select → Invert) し、それらの線を非

表示(Mesh → Show/Hide → Hide Selected) にします。垂直線のみが残りま
す。

③　長さ  9m  以上の線を選択(Select → Select Similar → Length  で左下の

compare を  Greater) します。非表示の線を表示(Mesh → Show/Hide → 
Reveal Hiddn) し、その逆を選択(Select → Invert) すると  9m  以下の垂直線が
全て選択されます。

④　その線に接続する線を選択(Select → Select Linked → Linked) すると  3  階以
下の建物が全て選択されます。

4  階以上の建物 (陸屋根で高さ  9m  以上)を切出す方法

以下の手順があります。6.2.4  項に更に詳しく解説しています。

①　建物を陸屋根(Flat) 指定で  OSM  から  Blender  に展開します。(3.2.3  項)

②　これ以降は  3  階以下の建物を切出した方法を参考にして  3  階以下の建物を選択
します。
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(4) 切妻屋根の庇(ひさし) を出す方法
切妻屋根の庇を建物の側面から飛び出す様にすると日本家屋らしく見えます。以下
にその操作方法を記載します。

以下の方法は不正確なため  Python  スクリプト(未記載)を使うの方が良いようです。

概略作業は、建物オブジェクトのコピーし片方のオブジェクトを個々の建物オブ

ジェクトに分け、それらオブジェクトを  Individual Origins  で  XY  方向に少し拡大

し、最後に  Wall  の部分を削除して屋根にする作業になります。

具体的な操作の流れは以下の通りです。

①建物オブジェクトのコピーし  Edit Mode  で全体を選択してから個々の建物オブ

ジェクトに分けます。（Mesh → Separate → By Loose Parts) 

②  Object Mode に戻り個々のオブジェクトの中心に  Origin  を移動します。これには

3  分程度かかります。

(Object → Set Origin → Origin to Center of Mass (Surface)) 

③ピボットポイントを  Individual Origins にします。

④  S  キーを押し、マウスで少し拡大したあと  Shift＋Z  を押し、1.15  を入力します。

⑤個々の建物オブジェクトを  1  つに合体します。(Object → Join) 
これには  10  分程度かかります。

⑥  Edit Mode  に戻り  Material  が  Wall  であるメッシュを  1  つ選択しその  Material  の
メッシュを全て選択します(Select → Select Similar → Material)。

⑦そのメッシュを削除します(Mesh →Delete →Faces )。

もう一方の建物オブジェクトの  Material  が  Roof  であるメッシュを削除し、前述の

オブジェクトと合体(Object → Join ) します。l

4.3.3 Object タブの設定
X-Plane オブジェクトにする予定のオブジェクトを選択し右画面の Object タブ(Object 
Prperties) を開いて以下を設定します。

(1) ▼X-Plane 欄にて最初は右図の様に

Root Object はチェックされていませ
ん。

対象のオブジェクトが X-Plane 用オブ

ジェクトに変換する予定がなければ、このまま (14) 以降の設定に進みます。

X-Plane 用オブジェクトに変換する予定があれば (2) に進みます。

(2) Root Object にチェックを入れ、

▶ Root Object をクリックします。

(3) Name: 　X-Plane オブジェクト(OBJ) 
の名称を入力します。

(4) Type: 　Scenery Object を選びます。

(5) Textures 　以下の画像ファイルを指定
します。

Default: 　昼用画像のファイルパス

Night: 　夜用画像のファイルパス

Normal / Specular: 　表面光沢設定用
画像のファイルパス

Draped:　ドレープ型オブジェクトの昼
用画像のファイルパス

Draped Normal / Specular: 　ドレープ
型オブジェクトの表面光沢設定用画
像のファイルパス

注　画像ファイルが Blender と同じフォ
ルダにある場合は、この画像ファイ
ル名欄はファイル名のみで、パスを
付記する必要ありません。

(6) Global Material Options
Blend Glass　（詳細不明）

Normal Metalness　表面に光沢を設定
したい場合にチェックします。

Normal Metalness (Draped) 　ドレー
プ型オブジェクトの表面に光沢を設定
したい場合にチェックします。

注　Metalness (光沢) を設定した場合は、XP11 用機体作成メモ(後編) の 8 項　　

に従って画像を作成し、上記(5) で指定する必要があります。    
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(7) Levels of Detail　X-Plane オブジェクト内の全ての子オブ

ジェクトに共通に適用される LOD の具体的な表示範囲を設

定します。個々の子オブジェクトについては、項の Override
LOD:で表示範囲を選択します。表示範囲は近いものから順

に、Lvel of Detail 1→ Lvel of Detail 2 → … Lvel of Detail 4 (最
大) ので指定します。                                   

LODs: LOD を設定する総数(最大 4)を指定。各 LOD 表示範
囲の設定欄が現れます。

Near: LOD 範囲の近限界(単位 m)を指定。
Far: LOD 範囲の遠限界(単位 m)を指定。

                                                       
注 各 LOD 範囲に隙間がない事。そうしないと画

像がちらつく場合あり。つまり、ある範囲の
遠限界と次の範囲の近限界は等しいこと。
    

注　LOD を設定しなかったら、メッシュは強制的
に one- sided として扱われるらしい。        

                                                    
Max. Draped LOD: ドレープ型オブジェクトの場合は、

処理速度を悪化させない様に通常型オブジェクトよ
り近くても表示を中止します。その表示最大限界を
指定します。(単位 m)
0.00 (ディフォルト) は出来る限り表示するの意味。
上記の Type 設定で Instanced Scenery である事。

(8) Layer Grouping

Layer Group: 　X-Plane オブジェクトをグループごとに纏
めて描画したい場合があります。そのグループ名として
Layer Group 名を指定します。以下の中から選びます。他
の名前は使えません。

Cars, Light objects, Objects, Roads, Airports, Markings,
Runways, Taxiways, Shoulders, Beaches,  Terrain, None 
ディフォルトは None で、グループに含まれない通常の

X-Plane オブジェクトの意味。

Layer Group Offset
同じ Layer Group 内で書き込み順が正しくない場合はこの

値で順番を調整します。X-Plane に順番をまかせる場合は

0 とします。-5～+5 の数字で設定します。-2 の設定では

X-Plane の決めた順番より 2 レイヤ先にこの Layer Group を描きます。

Draped Layer Groupe: 　詳細不明

Draped Layer Groupe offset: 　詳細不明

(9) Slope Properties　シーナリの地形メッシュの傾きで、オブジェク
ト表示をするかしないかを決めます。

Slope Limit   地形の傾斜角度がある値を超えた場合そのオブジェクト
を表示しない場合はチェックし、その限界を次に設定します。建
物の土台までオブジェクトに含まれている場合は、この限界は大
きくても良いはず。複数のオブジェクトをまとめてある領域に配
置した場合でも、X-Plane はそれぞれのオブジェクトでこの判定
を行うとのこと。

オブジェクトの前方を Y 方向、右方向 X 方向とする。-90 から
90 の範囲で角度を指定すると、

Min. Pitch: obj の前方が下方向に回転した時の表示限界角度(°) 　
Max. Pitch: obj の前方が上方向に回転した時の表示限界角度(°) 
Min. Roll: obj の左側が下方向に回転した時の表示限界角度(°) 
Max. Roll:    obj の左側が上方向に回転した時の表示限界角度(°) 

Tilted     地面が傾斜している場合、オブジェクトも同様に傾ける時に
チェックします。

(10) Require surface　そのオブジェクトが地上にあるか水上にあるか
で表示を切り替えられます。例えば橋げたの場合、水上のオブジェ
クトと水中のオブジェクトの両方を作成しておくと、水に濡れた色
が表されるそうです。

Any　地形メッシュが水面(Wet)であるか陸上(Dry)であるかにかか
わらずオブジェクトを表示する。　　　　

Wet　地形メッシュが水面(Wet)の場合のみオブジェクトを表示する

Dry　地形メッシュが陸上(Dry)の場合のみオブジェクトを表示する。

(11) Advanced Options 
詳細不明

(12) Laminar Library Directives: 
詳細不明

(13) Custom Properties: 
詳細不明
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(14) Datarefs 　Add Dataref を押して、

使用する Dataref を設定します。

詳細は XP11 用機体作成メモ(後
編) の４項を参照下さい。

Manippulator      シーナリでは使用不
可のはずです。チェックしません。

Override LOD　　

LOD:　事前に(7)で LOD の設定番号
が設定されているので、当該オブ
ジェクトがその番号のどれを適用
するかを指定します。チェック
ボックスの左から、Level of detail
1, Level of detail 2, Level of detail 3,
Level of detail 4 となります。全て
にチェックが入っていない場合は
全ての LOD 範囲で表示されるものとされます。

                                                                
Override Weight　オブジェクトの間でどれを優先して表示するかの順序を指定す

る様です。詳細不明。
Weight:       ディフォルトは 0。X-Plane の順序に任せるの意味の様です。

                          
Custom Properties     詳細不明                                               
Custom Animation Properties  　詳細不明
Conditions    　詳細不明

(15) ▼Viewport Display

Shadow にチェック入れます。

Display As 　は通常

Textured にします。この

オブジェクトは Textured 
で表示されます。 

4.3.4 Material タブの設定
対象オブジェクトを選択し右画面の Material タブ(Material Properties) 　　にて以下を
設定します。

(1) ▼Surface で Use Nodes が選択(灰色表示)
されていない場合は、Use Nodes ボタン
を押します。テクスチャ設定項目が表示さ
れます。

(2) Base Color
最初は　　が表示されています。その場合

は右端の丸印をクリックし Image Texture 
を選択します。
次の行で画像ファイルを指定します。

(3) この行は Single Image を選択します。

(4) Color Space: は Non-Color を選択します。
こうしないとテクスチャが暗くなります。

　　　　　　　　　　　　　　　　　　　　　　　　　　（次頁に続く）
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　　　　　　　　　　　　　　　　　　　　　　　　　　（前頁より続く）

以下の項目はとりあえずそのままにします。

（詳細不明）

(5) Draw Objects With This Material
当該オブジェクトを描画する場合は
チェックを入れます。
参照用オブジェクト等で描画する必要な
い場合はチェックを入れません。

(6) Draped
チェックするとこのオブジェクトをド
レープ型に宣言します。ドレープ型に設
定すると X-Plane 上で地形メッシュに張

り付いた形で表現されます(道路等)。
建物等はチェック入れません 

(7) Blend: 　以下のいづれかを選択します。

Alpha Cutoff　貼付け画像の α 値で透明

/不透明の区別を分ける。カットオフ

比率 α は下に表示される Alpha Cutoff
Ratio で指定します。

Alpha Blend　貼付け画像に透明部分が

ある場合その通りに表現する。(通常

これを使います)
Shadow 　不明

(8) Surface Type: 　ディフォルトは None 
特に分類しない普通の面の意味。

他に Blasted, Shoulder, Snow,
Lakebed, Gravel, Dirt, Grass, Asphalt,
Concrete, Water　から選択可能。

(9) Camera Collision  　シーナリでは無効と思われます。飛行機のコックピットの場
合のみ有効のはずです。

(10) Override Light Level 　夜間のオブジェクト画像を Dataref で制御する場合に
チェック入れます。例えば光がゆっくり点滅する等の効果を出せます。

Value 1:　 Dataref の値がこの値以下の時、Override 強さをこの設定値にします。
Value 2: Dataref の値がこの値以上の時、Override 強さをこの設定値にします。 1

以上も設定可能。                                                
Dataref      画像の制御され方を指定する。 Value1 と value2 の間は補間されます。

(11) Polygon Offset 　　原則として X-Plane は遠いオブジェクトから近いオブジェクト

の順に描画します。通常 X-Plane にその順番を任せるので、0（ディフォルト）に

設定します。描画順を指定したい場合は順番 1～を指定します。数字が多いほど上
に描かれます。
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4.4 シーナリーパックの作成

4.4.1 オブジェクトの準備
3.2 項で作成した Hiroshima_updated フォルダをシーナリパックとし、その下に

objects というフォルダをつくり、その中に以下の X-Plane オブジェクトを保存します。

(1) 3.3 項で作成した地形メッシュに以下の修正を施しオブジェクトを保存します。

・Material が terrain_Water であるメッシュは削除しテクスチャ設定する。

・ドレープ型を設定し(4.3.4 項(6) 参照) 、Layer Grouping で以下を設定する。

(4.3.3 項(8)参照)
　　Layer Group は “None”
　　Layer Group Offset および Draped Layer Group Offset は “1”

(2) 道路については、4.2.3 項で切り出した map.osm_motorway 等のオブジェクトを参

照し、長方形オブジェクトの 1 辺を excludeしながらて道路オブジェクトを保存し

ます。ドレープ型を設定し(4.3.4 項(6) 参照) 、Layer Grouping で以下を設定する。

(4.3.3 項(8)参照)
　　Layer Group は “None”
　　Layer Group Offset および Draped Layer Group Offset は “2”

(3) 4.2.3 項で切り出した map.osm_buildings のオブジェクトを保存します。

4.4.2 WED での設定
WED を立ち上げ、Hiroshima_updated を選択し OPEN ボタンを押します。空港情報

(apt.dat)がなくて保存できない場合は、File → Import from Airport Scenery 
Gateway メニューからとりあえず近くの空港を取り込み、保存します。

WED の背景に衛星画像を表示し、前項のオブジェクトをシーナリーに配置します。そ
の際以下の調整が必要になります。

(1) オブジェクトの水平方向位置は latitude や longitude で修正します。

(2) オブジェクトの縮尺はオブジェクト側のサイズを修正するしかありません。

(3) オブジェクトの高さは通常 Elevation Mode を On Ground としますが、ズレている

場合は set MSL 又は set AGL で修正し、X-Plane で高さ方向の位置が正しいか確
認します。

注　オブジェクトに Draped の指定をした場合は、X-Plane 上では地面にピッタリくっ

つくのでその必要ありません。ただしその場合は On Ground でオブジェクトを
配置する必要があります。

その他、Exclusion Zone も設定します。最終的
には右の様なオブジェクト構成になりました。

4.4.3 シーナリパックを構成するもの
今回の例ではシーナリパックは最終的に以下の構成となりました。このシーナリーは

空港シーナリーでないので、最初に付加した空港(apt.dat) を削除しました。

Hiroshima_updated /
　├ Earth nav data /
　├ objects /
　│　├ Hiroshima_terrain_OBJ.obj
　│　├ Roads.obj
　│　├ High_Buildings_Flat.obj
　│　├ Low_Buildings_Gable.obj
　│　└ Hiroshima_terrain.png
　│
　└ earth.wed.xml

今回のシーナリー例の仕様

　　地域：広島市中心街、約 4Km 四方

　　低層建物(切妻屋根) ：約 48,690 戸

　　高層建物(陸屋根) ：約 4,150 戸

　　ファイルサイズ：121 Mb
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今回の例では下図の様なシーナリになりました。（Python スクリプトによるテクス
チャ貼りつけ未）
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5. Billboard 作成                     

例えば OSM データを使ってシーナリーを作成した場合、そのシーナリーに 

ⒸOpenStreetMap contributors を表示することが求められています。(下記 URL)

https://www.openstreetmap.org/copyright
その為、この内容を表示する板をシーナリーに配置したいのですが、ユーザーから見
る角度によっては見え難い場合が有ります。この様な場合に下図の様な Billboard が有
効です。以下その作り方の例を解説します。

ただし、シーナリーに Billboard を使ってクレジット表示する方法が妥当かについての
公式な結論はまだ出ていません。個人の責任の元にこの資料を参考にして下さい。

5.1 Billboard とは
X-Plane で Billboard はランプの光源画像として使われています。この光源画像は X-
Plane では常にユーザー視点の方を向きます。Billboard (広告看板) と呼ばれるのはそ

の性質によるものと思います。この Billboard はシーナリーでは各種案内掲示板等に使
えそうなので以下に解説します。

一般的にはランプは他のオブジェクトの子として配置するのが普通です。この場合

Billboard のテクスチャは親オブジェクトのテクスチャの一部を使います。(Texture 
Coordinates の設定による)
今回の例では、1 つの案内掲示板に近づいた時にその案内掲示板が現れる様にしたい

ので、1 つのランプを 1つのオブジェクトとし、LOD を設定します。

ランプの設定は以下の資料を参照できます。
LIGHTING:    https://sites.google.com/view/xpdc/general/lights

5.2 Billboard オブジェクトの例
(1) Billboard は Blender の 3D 画面原点にカーソルを置いて、Add → Light → Point メ

ニューを選択し点光源(Point) を追加します。追加した光源の名称は Billboard_OSM
としました。この点光源の位置に Billboard が置かれますが、この位置は後で WED
で修正します。

(2) 追加した光源(Billboard_OSM)を選択しオブ

ジェクト設定アイコン　　を選択し X-Plane
の下の Root Object にチェック入れます。

(3) Name、Type および Texture を設定します。

テクスチャ画像は必ず 2 のべき乗の上正方形
で今回の場合は全面を使います。今回の例で
は以下の画像を使いました。

 

(4) LODs (LOD 階層) を１とし、その Near (近限

界) を 0 (m)、Far (遠限界) を 5000 (m)としま
した。

(5) 下の方にある Override LODs にチェックを

入れ、LOD: の一番左にチェックいれます。

                                                                      28 / 29                                                                                                                     



(6) ランプ設定アイコン　　を選択し以下を設定し
ます。

Color:　白色にします。Billboard はこの色とテ
クスチャの色を合わせたものになります。

Power:　1 (0～1 の最大値)

Specular:　1(0～1 の最大値)

Radius:　0.5

Custom Distance:　詳細不明

Shadow:　詳細不明

Type:　Billboard を作る場合は Custom を指定し
ます。

Size:　Billboard の最大寸法(m) を指定します。

Texture coordinates:　オブジェクト全体のテ

クスチャ画像のどのエリアを Billboard の
テクスチャとして切出すかを設定します。
画像の左下が原点(0,0) 右端および上端が

1 になります。

全体のテクスチャ内で Billboard がどの位

置(左端、上端、右端、下端の順) にある
かを指定します。これら値を入れ替える
と左右または上下反転されます。

今回の例はランプ自体が Root Objectなので、テクスチャ画像全体を指定し
ています。

Dataref:　どのタイミングで点灯または消灯するかを指定できる Dataref があれば
設定します。常に点灯する場合は空欄とします。

Enable RGB Picker Override:　チェックしない。チェックすると色の補正値

(RGB Override) の入力が可能の様です。

Create lights.txt Summary:  使用方法不明。

(7) X-Plane オブジェクトにしたいものだけを表示
します。

(8) Save した後、シーン設定タブをクリックし、Export
OBJs ボタンをクリックします。

Export OBJs ボタンが一瞬青色になった後、.Blender
ファイルと同じ場所に Billboard_OSM.obj が作られま
す。

(9) 作成された Billboard_OSM.obj をシーナリーの Objects フォルダに入れます。

5.3 Billboard を WED で配置する
Billboard_OSMオブジェクトをシーナリパックの Objects フォルダに格納したら、

WED を立ち上げシーナリに配置します。

(1) 画面左上のリストで ▼Local→▼objects から

Billboard_OSM.obj を選択します。

(2) 画面中央のシーナリー平面上で Billboard を配置する場所をクリックします。

Billboard_OSM.obj が WED 内に配置されます。

(3) 画面右下のオブジェクト特性欄で正確な緯
度経度を入力します。今回の例では

 latitude    34.39375
 longitude   132.45185
を設定しています。
Elevation Mode で set AGL を選択し、

Elevation に 60 を指定します。

これで指定場所の 60 m上空に Billboard が
配置されます。

(4) WED の設定を保存してシーナリパックを保
存します。

以上の設定により、下図のような Billboard が X-Plane 画面に表れます。
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